8th Generation Honda Civic Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
476 Posts
Discussion Starter · #1 ·
When I bought my car before the civic, the previous owner had put in two 12inch off brand name subs. They hit decently when they were working but for some reason they stopped. I know it's the subs cause the amp I had at the time worked with a different sub. I have opened up the box and checked the connection of the wires and they are fine, but for some reason I can't get them to work.

Anyone got some ideas?
 

·
Registered
Joined
·
128 Posts
When I bought my car before the civic, the previous owner had put in two 12inch off brand name subs. They hit decently when they were working but for some reason they stopped. I know it's the subs cause the amp I had at the time worked with a different sub. I have opened up the box and checked the connection of the wires and they are fine, but for some reason I can't get them to work.

Anyone got some ideas?
Check to see if the subs is blown.. push the sub in with your hand, and if its still goin up and down it works, but if it feels like its hard then its blown..
 

·
Registered
Joined
·
476 Posts
Discussion Starter · #6 · (Edited)


This is what they look like. I have never heard of this brand before.

I pushed down on the right sub. And it seems to move up and down smoothly but the left one only goes down a little bit and comes back up pretty slowly so I think that one might be blown. Otherwise I have no clue whats going on.

If one sub is blown would that make it so both wouldn't work?

edit: I removed the plastic cover so you could see the subs better.
 

·
Registered
Joined
·
476 Posts
Discussion Starter · #8 ·
Didn't know that ej, thanks. I can't find any maker for these but i did find a set of them on ebay for $45 lol.
 

·
Registered
Joined
·
525 Posts
i had this problem too... it could be a couple things... but try simple things first.. did you check the fuse in your power wire that is connected to the battery? if that's blown then your subs wont work
 

·
Registered
Joined
·
2,469 Posts
i can probably help you as well I did my own subs. If you want we can meet up somewhere and ill check everything out.


Just PM me on whats up if you want to meet and your number.
 

·
Registered
Joined
·
476 Posts
Discussion Starter · #12 ·
I don't actually have the amplifier anymore as the car it came out of was totalled. Right now I have the subs sitting in my garage. And thanks 07NHBP i'll hit you up for more info.
 
1 - 12 of 12 Posts
Top