8th Generation Honda Civic Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
I bought a replacement aftermarket clutch because mine is failing to stay engaged. It said it was for a TRSE07 COMPRESSOR. It doesn't look like I have that. See picture:

20190706_123608.jpg

Here's what the replacement looks like:

20190706_140534.jpg

I really should have checked before I bought a replacement but I thought the odds were on my side. Do any of you fine gentlemen know what type of compressor I have so I can get the right clutch?

Also, what's the deal with that empty bracket? I haven't had this car for most of it's life and I don't know what's been done to it before me. Most of the clips that hold the splash guards and covers around the engine are gone so work was done to this in the past and I'm wondering if things are different or missing.

20190706_123614.jpg

Edit: Well it looks like that bracket is also empty on the video on YouTube that I was using as a guide so that's interesting. Why have that bracket if it's not used?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
Well I've been looking around online and have seen images of the ac compressor with this style clutch and they all say that this is the TRSE07. So why the different style of clutches? In theory this replacement should work then even though they are slightly different?
 

·
Registered
Joined
·
140 Posts
Aftermarket clutches will vary. Likely be fine. I put one on a few years back but the compressor eventually gave up the ghost after the fan went out and caused the pressures to go sky high.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Oh my this redesign is awful. I hate it in every way.

Anyhow, if anyone was curious, the replacement pulley was offset differently than the old pulley. It was pulling the belt off center. I put the old pulley back on but left the new coil and clutch plate and my AC has been working just fine for the past two weeks. Also, that whole job sucked and took me far too long. Pictures below if you wanna see the issue I had.


20190714_174406.jpg
20190713_231256.jpg
20190713_230506.jpg
 
1 - 5 of 5 Posts
Top