8th Generation Honda Civic Forum banner

1 - 8 of 8 Posts

Registered
Joined
22 Posts
Discussion Starter #1
Recently I have been noticing some issues with the termperate gauge on my 2019 Honda Civic SI.

When I start up my vehicle the gauge seems glitch out almost full bars with a few bars missing at the beginning and the end of the display eventually after driving the vehicle it will randomly return back to normal and once the car has been driven for a good amount of time the display shows up correct right in the middle of the C and H. I have attached some photos of what it looks like you can notice even the C and H display disappears while the gauge is "glitching" but then reappears.

Just wondering what might cause this? Electrical? Any ideas?
 

Attachments

Super Moderator
Joined
1,915 Posts
I don't remember seeing how to fix this other (I've seen similar issues with the speedometer and gas gauge) than to replace that cluster. Ebay usually has them, check there. Thankfully, these are easy to replace. BTW, that's an old looking 2019 Si, LOL. 馃ぃ
 

Registered
Joined
22 Posts
Discussion Starter #3
I don't remember seeing how to fix this other (I've seen similar issues with the speedometer and gas gauge) than to replace that cluster. Ebay usually has them, check there. Thankfully, these are easy to replace. BTW, that's an old looking 2019 Si, LOL. 馃ぃ
hahah sorry typo 2009*
 

Registered
Joined
22 Posts
Discussion Starter #5
How many miles on your car?
Had the same issue, replaced the thermostat.
Sorry for the late reply I have about 108,000 miles (174,000 KM) on it.

It seems to be happening a bit more often lately so the issue appears to be getting worse.

I will do some research online about the thermostat hopefully it's not a huge job.
 

Registered
Joined
22 Posts
Discussion Starter #6
it turns out that the issue I am having has nothing to do with the thermostat it's the dash cluster. When the issue happens if I tap on the dash it goes back to normal for a short period of time.

I pulled a part the dash to check the wiring everything looks good but I believe the upper speedometer cluster on my civic needs to be replaced.

I have the part number but I was wondering if it will need to be programmed for my vehicle? The mileage appears on my lower cluster but I would assume both clusters are programmed together?

Can anyone confirm this thanks!
 
1 - 8 of 8 Posts
Top