8th Generation Honda Civic Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My car has 4800 miles on it and since I purchased it brand new I have had a rattle in my sunroof. It has been to the dealership twice, they have heard the sound and have completely replaced my headliner and pull shade, but the problem has remained. Has anyone had this problem, and if so how can I get this fixed.

Thank you.
 

·
Registered
Joined
·
1,172 Posts
I had it when I first bought my 06...make sure all the plastic snapped in correctly...I believe someone else here or on vtec.net solved it but I dont remember how...just search it and you should come up with something
 

·
Registered
Joined
·
622 Posts
i have the same thing. i think its a metal piece for the sunroof underneath the liner. i havent gotten around to fixing it...i also have a nasty rattle in my b pillar right next to my ear. its soooo annoying!
 

·
Registered
Joined
·
661 Posts
i have this experiences since i got my car a year ago, but never add this one to my list, i just dont close the cover all the way, leave about 1/8 inch or less than then the noise is gone:laughing:
 

·
Pillar of Objectivity
Joined
·
8,915 Posts
I had this problem as well, with it sounding like it was about to fall off on me. No problems for 11,000 miles, and then it just appeared.

My dealership did something to it and it fixed it...for now.
 

·
Registered
Joined
·
1,775 Posts
I know exactly what you are talking about. It's the rubber seal around the class that meets with the body of the car. It rubs when you go over bumps or even just driving make an annoying creaking sound. Here is a link to a DIY that I tired and it helped a lot. I didn't hear the sound, now I just reapply that stuff every 3 months or so and its all dandy.

http://www.8thcivic.com/forums/showthread.php?t=17170
 

·
Pillar of Objectivity
Joined
·
8,915 Posts
^ I knew that's what it was Tim.

I looked at my car before I took it in, and heard that sound, and noticed when I gently pushed up on it from the inside while closed, it made a squeaking/rubbing sound.

And when I looked at it from the outside, the seal was uneven, and caved in a bit towards the back.

The dealer said this was normal, of course. Funny they didn't mention WHAT they did to fix it!
 

·
Registered
Joined
·
58 Posts
i had the same problem, took it to the delership and still the same thing, read all of the posts on here and now have almost completely fixed it. there is a diy on her somewhere where about it.
the problem is very simple in most 8th gens. dirt gets lodged in between the sunroof weatherstrip and the sheetmetal of the roof.
- take alchohol and clean the weather strip and wipe down the sheetmetal as well.
- then take silicone spray (do not use wd-40, it will rust) spray it on a rag and wipe down the entire area.
this is a very brief version of how it is done but it works. my rattle only appears once in a blue moon now.
i will try and find his diy as it is very informative and actually works.

HOPE THIS HELPS

****************WHOOPS TROGER BEAT ME TO IT **********************
 
1 - 9 of 9 Posts
Top