8th Generation Honda Civic Forum banner

1 - 20 of 135 Posts

·
Registered
Joined
·
236 Posts
Discussion Starter #1
also replaced rad hoses with S2, installed everything and all is fine except for erratic idleing and i cant rev past 3800 rpms unless i reset everything and then after a few shut offs and back ons it all starts back...it was all stock before this install...but here are some pics..

stock



and it starts









stock intake and TB out!







annd couldnt get this thing out for ****..







after about an hour it came out!



pic of the gf



first piece of skunk hardware!











installing the intake





finished!



:eek:hsnap:
 

·
Premium Member
Joined
·
2,947 Posts
Nice you dont have flashpro? I would think it needs idle relearn procedure and if you have flashpro a nice tune to iron out the bugs and get some ponies out of her. On a side note that engine bay needs a bath and a half.
 

·
Premium Member
Joined
·
2,947 Posts
Yeah like i said if you dont have flashpro when removing the throttle body you will need to do a idle relearn procedure. Its on this forum somewhere this will fix that issue and you should be good to go.
 

·
Registered
Joined
·
28,322 Posts
also replaced rad hoses with S2, installed everything and all is fine except for erratic idleing and i cant rev past 3800 rpms unless i reset everything and then after a few shut offs and back ons it all starts back...it was all stock before this install...but here are some pics..
I wouldn't consider that to be all fine with issues like that.

Your GF looks thrilled to be there.


The erratic idling is because your PCV valve hose is not connected to anything


:face-puke Is that standing water on your OEM manifold?


Dare I ask what the Superglue was used on?


You need FP ASAP! :readtherules:
 

·
Premium Member
Joined
·
12,586 Posts
the intake manifold should have come with a black plug for the pcv valve. i have both s2 mani and tb, and no issues right now.

i have to ask though...did you threadlock and teflon tape the vacuum on the top of the tb? (the grey tube that sticks up and out of the tb) i did not do that and experienced the weird idle (not saying that it accounts for the idle, but after i threadlocked, teflon taped, siliconed the crap outta it, i havent had any idle problems)
 

·
Registered
Joined
·
236 Posts
Discussion Starter #19
the intake manifold should have come with a black plug for the pcv valve. i have both s2 mani and tb, and no issues right now.

i have to ask though...did you threadlock and teflon tape the vacuum on the top of the tb? (the grey tube that sticks up and out of the tb) i did not do that and experienced the weird idle (not saying that it accounts for the idle, but after i threadlocked, teflon taped, siliconed the crap outta it, i havent had any idle problems)
Yeah I used Teflon tape on it
 
1 - 20 of 135 Posts
Top