8th Generation Honda Civic Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
hello guys ive searched around on this topic for a bit before posting.

Recently cleaned the throttle body, yes i opened it using the throttle and cleaned it didnt push the flaps by hand and stuff. but now when am in neutral the rpm surge between 2k all the way upto 3k and come down and then go up again and keeps doing it untill the car fully stops WHEN IN NEUTRAL AND COASTING

and it idles around 900-1k but before the cleaning it used to idle perfectly.

another thing when going to change gears the car revs up for some reason now? and when i let go of the throttle in gear it takes a second and then i feel like the throttle is let go.

No codes only codes i have are for an O2 sensor and evap code

what should i check for next? new throttle body? MAP sensor? MAF sensor? am all out of ideas
qazz96 is offline
Add to qazz96's Reputation Report Post
 

·
Registered
Joined
·
78 Posts
There is normally sounds like a huge vacuum leak. double check all the plugs. This happened to me when i forgot to plug the throttle body back in. Ive cleaned several DBW throttle bodies with my hand and moved it open and closed and they worked just fine afterwards. Also Try unplugging the battery and resetting the ECu
 

·
Banned
Joined
·
32 Posts
Clark Kent is one in a million. No, really, that's understating it. Clark Kent is one in a lifetime, perhaps one in several lifetimes. Clark Kent is the perfect combination of nature and nurture needed to create an individual who can be trusted not to abuse his godlike Kodi nox powers.
 

·
Registered
Joined
·
56 Posts
The throttle body resets itself and self-calibrates every time you turn the ignition on. I'd say your maf sensor got yanked when you had the TB exposed. But also sounds like a vacuum leak or the boot isnt full on the TB.
 
1 - 7 of 7 Posts
Top