8th Generation Honda Civic Forum banner

21 - 23 of 23 Posts

·
Registered
Joined
·
226 Posts
Sensor for regular fan is located at bottom of radiator. The relay in the under hood fuse box controls the switching. Test fan by manually powering it up. If it spins up likely a bad relay or sensor. Check wiring if suspected.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
8 Posts
My fans aren't working either,I tried to jump the wires nothing,tap on fans nothing.I ordered one relay and two diodes for under the hood fusebox,no change,among fan related and other fuses,new thermostat,new temp sensor,clutch relay,even new ac compressor.There is a fan relay under the glove compartment I also replaced,the ac and heater works now.It has a resistor that's blown,it can be replaced I found out after I bought the relay.
 

·
Registered
Joined
·
8 Posts
My fans aren't working either,I tried to jump the wires nothing,tap on fans nothing.I ordered one relay and two diodes for under the hood fusebox,no change,among fan related and other fuses,new thermostat,new temp sensor,clutch relay,even new ac compressor.There is a fan relay under the glove compartment I also replaced,the ac and heater works now.It has a resistor that's blown,it can be replaced I found out after I bought the relay.
Ok so I'm answering the radiator fan issue.After this work at replacing parts,I decided to give the Mechanic this repair.And sure enough it was the Batterry,Alternator also was not charging the Battery,and the ac wasn't spinning,so he put the old ac back in,and refilled it so the fans started working.
 
21 - 23 of 23 Posts
Top