8th Generation Honda Civic Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
Hey guys, need some help here.

I've been having this problem for quite a while now. About 2 months ago I noticed my exhaust leaking from the connection closest to the muffler. I figured, easy enough, I'll get a new gasket and swap it out. I got a new gasket and brought it to a shop to have them do it for me as I am at school and don't have any tools. When they went to replace it they said my flanges were warped. Luckily, I ordered 2 replacement gaskets so they put both in and stopped the leak. Now, within the last week, I noticed the next connection up the exhaust is leaking. This time I called invadia and they sent me replacement gaskets for free.

I asked about warranty because this seems odd, but I'm only a month out of the year warranty.

Now today, I went to get the other leak fixed with 2 gaskets again. They fixed it and also noticed that these flanges were also warped. This time the shop told me that they 3 bolt flange, connecting to the stock header, is slightly leaking. Eventually I want to get a header, but this is making a little uncomfortable with getting an Invidia header. Has anyone else experienced something like this? I mean i understand gaskets can blow from time to time, but this does not seem right. Let me know if anyone has any insight or what I should do, or if you are having the same problems.

Thanks!
 

·
Registered
Joined
·
572 Posts
What does yours sound like?

I got MP header into Q300....and on cold starts, I get a metal tingy sound (scientific term ;) )...I replaced the donut gasket on my header connection.

I don't see any carbon track marks, but the sound is def near the header-midpipe section.


Once the car warms up, it sounds much better.



And, those updated connections definitely look better.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #5
I hate to bring this thread back, but I'm again having the same issue. The flange before the axel back section is warped and leaking. I was advised to use 2 gaskets to re seal the connection, so I did that. That is not working anymore. Basically, both of my 2-bolt connections on my q300 exhaust are warped and leak.

I contacted Invidia with this issue with I was about one month out of warranty. They did not offer much help, except they sent me a new flange. That was only a minor bandaid. Is this something I should pursue again by contacting Invidia?

I am not even close to the type of person who will be pushy or rude, but I feel very let down by their product. I wanted this exhaust for so long, and now it is like I'm forever chasing warped flanges and blown gaskets. I could order 4 new gaskets and put 2 at each flange, but I feel like that will just be another band aid. I do not want to band aid this forever.

Do I try to press a little bit against Invidia and express my unsatisfaction? If so, how would you do it? Or am I s.o.l? I will never bad mouth a company, and I truly believe Invidia makes quality products, but this definitely makes me wonder if I should get an Invidia header or not.

Thanks for any help that is offered! Also, my flanges do not look like the flanges that Dar-Dar posted
 
1 - 5 of 5 Posts
Top