8th Generation Honda Civic Forum banner

1 - 20 of 39 Posts

·
Premium Member
Joined
·
112,534 Posts
Discussion Starter #1
I went to the track on friday. I installed a torque dampner about two weeks ago. When I would launch hard my car would pop for some reason. Then everytime i changed gear and had my foot on the gas it would pop again. Im not sure if its the torque dampner doing its job but it was loud as hell. Does anyone know what the problem is? Im not sure what setting its on i put it on how it came. Someone let me know.
 

·
Premium Member
Joined
·
112,534 Posts
Discussion Starter #3
Yeah it was loud. It did it once on regular driving as well. I stopped hard and it popped. I thought something broke but it still drives fine.
 

·
Premium Member
Joined
·
112,534 Posts
Discussion Starter #5
I have sportline springs, torque dampner, front h brace and rear sway bar. But it pops from the fron.
 

·
Premium Member
Joined
·
112,534 Posts
Discussion Starter #7
Hell yeah it is. I was like NOOOO wait YEESS wait NOO lol. Oh well i guess ill get used to it when launching hard.
 

·
Registered
Joined
·
3,382 Posts
There have been countless threads on popping on this site. Use the search function. It works.

It's happening on a LOT of Si's, and it's the reason I won't take mine to the track.
 

·
Registered
Joined
·
4,949 Posts
RWatters said:
There have been countless threads on popping on this site. Use the search function. It works.

It's happening on a LOT of Si's, and it's the reason I won't take mine to the track.
i believe it is coming from the front dampeners and there is a tsb out for the fix.
 

·
Premium Member
Joined
·
112,534 Posts
Discussion Starter #15
Yeah but im not under warranty no more. do you know how much it will cost? I saw the TSB already.
 

·
Registered
Joined
·
2,273 Posts
its wheel hop. i thought it was bad at first too...when i first launched my car bad...but my friends from the outside said it was just wheel hop when they saw my car...and when i get wheel hop and launch hard...especially at the track...you hear the popping noise.
 

·
Premium Member
Joined
·
112,534 Posts
Discussion Starter #17
originalg00kster said:
its wheel hop. i thought it was bad at first too...when i first launched my car bad...but my friends from the outside said it was just wheel hop when they saw my car...and when i get wheel hop and launch hard...especially at the track...you hear the popping noise.
Do you have the Dampner on as well?
 

·
Premium Member
Joined
·
9,601 Posts
before the TD install ... the pop would be there and it is usually caused by the engine rocking on the front dog bone ... as it moved it would pop ... if it wasn't at that bone it was at the lower mount ...
but that one bolt on the dog bone would actually move ... well i could see it on my car(the marks where it moved)

now that u've installed the TD this shouldn't be happenning ... but if it is, it may be beacuse the bolt at the front dog bone is not tight enough, thus creating a weak link ... if i'm not mistaken the TD uses the same bolt as the dog bone ... if that bolt is not secured then u'll get that popping again ...

if that's not the cause then check ur struts ...

don't know what else it could be.
 

·
Registered
Joined
·
3,382 Posts
reaper702 said:
i believe it is coming from the front dampeners and there is a tsb out for the fix.
Last I heard there was a TSB out to fix a bumpstop. Given that my car is lowered I'm not going to waste my time with that TSB right now as I guarantee I won't get anything done.

I have the Ingalls ETD and my car still does it as well. It's in the strut like I've said since day one. How a "bumpstop that is binding when making turns" is causing it on a straight road I'm not sure.
 
1 - 20 of 39 Posts
Top