8th Generation Honda Civic Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello Everyone,
Recently bought a 2009 Fg2. Decided to go with the Skunk 2 Alpha headers. After Installing them I realized that the primary o2 sensor is abutting the shift linkage. I also installed the Hasport 70a. Has anyone else had this issue and if so are there any remedies? Thank you!
 

·
Registered
Joined
·
51 Posts
Hmm i have an 08 and my header brand is megan racing so they are different but is there a way to bend the linkage bracket over a little or possibly adjust your exhaust hangers so they arnt on top of each other? Im surprised S2 designed the header with the bung directly across from that linkage.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks for the reply. I was also surprised I have seen videos of these installed and no one has mentioned this issue. I wonder if the o2 bung was welded slightly off. I might contact skunk 2 for advice.
 

·
Registered
Joined
·
51 Posts
hmm i stalled the same motor mount but i dont belive i lined the engine up in the front correctly. i took the front mount bolt out to get the rear one in but now the end of my header pints up and my exhaust leaks att the donut gasket. i think i need to loosen it position the engine with a jack the torqu the bolts down again maybe that might work for u too
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top