8th Generation Honda Civic Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
206 Posts
Discussion Starter #1 (Edited)
well i was getting around installing my power wire , when i had just hook it up to the positive terminal w no fuse holder yet , i was getting around to move the already disconected negative terminal when i accidentally touched my neg with my hand the two conecctions didnt touch but i was holding the neg and moving it out of the way the side of my hand touched the negative batt terminal !! i heard a really small spark no smells or nor i felt anything '? could i have shorted something out!!!!! the power isnt hooked up to the amp yet
 

·
Registered
Joined
·
206 Posts
Discussion Starter #8
thanx guys ! this has taken me sooo long , and had many bumps building the sub box finally done but i used the wrong fabric very similar but it leaves some fibers out every time you rub it !! so its staying there until i build a new one bcause this one is way too big my fault! i hope i finish it today , i already routed the power all the way to the back seat
 

·
Registered
Joined
·
206 Posts
Discussion Starter #9
Helpppp again well i have finished my install then ran into a little problem looks like my really nice RCA cables damaged my "installedge" LOC , because they tight so much !

i had to plug & unplug em a couple of times and the last time i might of broke the port inside cause it only works a certain way if you move it the subs stop working right now its working but maybe when i drive it will get damaged again ?? would it be easier just to open it up and resolder the connection ? to fo this i need to remove the taps from my cables how do i do this ? looks impossible since the splicer is in there already
 

·
Registered
Joined
·
1,136 Posts
Do NOT hook up an amp without a fuse. Just wait till you get one. Its one of the most unsafe things you can do in car audio and not to mention you can burn up an amp if something goes wrong.
 

·
Registered
Joined
·
1,136 Posts
This might be one of those cases where you should just pay someone to do it. In the end you could cost yourself way more in damages than you would pay in installation.
 

·
Registered
Joined
·
206 Posts
Discussion Starter #12
thanx avalanche , actually thats not what happend i do have a fuse and a fuse holder and everything is now working fine i will post pics asap , what happend was that i didnt have them plugged in yet and i moved the unplugged negative out of the way and by accident WHILE holding the neg my hand touched the battery negative terminal and i heard alittle spark but my amp wasnt hooked up yet or anything i was just afraid of burning my cable some how................


NOW my current problem is that when hooking and unhooking the LOC to my RCA cables during the installation i might of damaged one of the LOC RCA ports and only works if the rca is jiggled a little and then left untouched but i am afraid with time and driving it will stop working so.... should i open up the LOC and resolder the connection?
 
1 - 13 of 13 Posts
Top