8th Generation Honda Civic Forum banner
1 - 7 of 7 Posts

·
Banned
Joined
·
171 Posts
Discussion Starter · #1 ·
Today, my friend and I installed the DDM 35w 6000k hids. The driver side was really easy. However, the passenger side was another story. First, we had to take off the wheel on that side. We barely got the fender liner off, and one clip on the bottom would not come off. So we had to snake in our hands to get the HID lights in. Anyways, we wired up the HIDs to the harness I got. Everything worked great! We proceeded to put everything back together and what do you know, no light! The relays wouldn't click and no hum from ballast. My friend traced the problem back to a loose connection between the light on the driver side and the harness. He zip tied the connectors together and they worked as I drove about ~20 miles around bumps and the lights were fine.

Now on to the problems:
1. The clip design for the wheel liner is really dumb. It is a hassle.
2. The case the DDM Tuning people put the HIDs in was really dumb. It was a 2 part plastic case where the long end came off, but the other end that screwed would only come off by breaking the plastic.

Now, on the the more major problems:
1. The driver side connection is loose between the bulb and the harness, my friend zip tied it together and it is holding. Do you guys think this will stay in the long run?

2. Just leaving my house, one person high beamed me. Then, a little while later another person high beamed me. However, I passed two cops, and they didn't do anything. I will post some pics of it up later. Is there any way to reduce glare? Can the low beams be adjusted?

Thanks!
 

·
Registered
Joined
·
2,489 Posts
Dam you got flashed at for 6K's? @[email protected] where do you live?
I live in MA. I wonder if I'll get pulled over for 8K's from DDM ( I know i know. 8k's = rice but. "to everyones own preference and yeah.. I know about the bad output. What ever *shrug*)
Mine are coming in tomarrow.
Hope my connectors aren't like loose like yours.
 

·
Registered
Joined
·
1,979 Posts
My connectors are a very positive lock, DDM and Apexcone. That's odd you have a loose one just because of the design.

Your aim is probably quite off, get on that ASAP. Do a search for aiming headlights.

Oh, and with the case, you don't have to break the plastic if you just unclip the bulb leads from the ballast leads, then you can slip it off one wire at a time.
 

·
Banned
Joined
·
171 Posts
Discussion Starter · #5 ·
thanks for the pic, but I'm having a hard time seeing where that is. What part of the engine bay is this from? Thanks

Btw, I am in NJ. I think I got flashed at for the glare though.
 

·
Registered
Joined
·
628 Posts
Dam you got flashed at for 6K's? @[email protected] where do you live?
I live in MA. I wonder if I'll get pulled over for 8K's from DDM ( I know i know. 8k's = rice but. "to everyones own preference and yeah.. I know about the bad output. What ever *shrug*)
Mine are coming in tomarrow.
Hope my connectors aren't like loose like yours.
man i love 8ks thats not rice. and i ordered 8ks from ddm and they gave me 6k. im so pissed.

but anyways the 6000k isnt illegal. and try and take a pic of the connectors, mine went in pretty smoothly i just hid my ballasts by the airbag sensor kinda behind the bumper which i took off. the only problem was the actual bulb getting to snap into place
 

·
Registered
Joined
·
1,106 Posts
my friend had 12k on his tc damn it was purple/blue he got high beam and finally pulled out but now he has 10k and is okay. doesnt get flashed. i have 6k on my civic and dont get flashed except for my time.
 
1 - 7 of 7 Posts
Top