8th Generation Honda Civic Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
1,031 Posts
Discussion Starter · #1 ·
Well, I got my LaminX pre-cut overlays installed by "The Shades of Grey", the LaminX's recommended installer - a quite reputable and professional company - about 6 weeks ago. First, but not immediately, more like after 3 weeks, the inside edge (towards the bottom of the inside part) started to peel off a bit, I tried to smoothen it with a vinyl applicator, but that didn't work.



Then today I saw that the upper border started to get all ugly:




Now I have a couple of questions:

a) Did it happen to any other LaminX owners here?
b) Why did it happen? Cold?
c) Is there a doable fix?
d) If I drive back to this guys, can they tell me that since it's been like 6 weeks they r not at fault, etc.?


Tnx in advance.
 

·
Registered
Joined
·
6,542 Posts
I just took some time to appropriately look at these pix. There was an install mistake. There's 3 ways to correct this.

1.) get a heat gun, and do it yourself w/ a credit card (smooth them out again)
2.) get some super glue and glue em down
3.) take it back to the shop who screwed it up.
 

·
Registered
Joined
·
1,031 Posts
Discussion Starter · #7 ·
take it back to the shop who screwed it up.
Yup, going there tomorrow, 20 miles drive... I guess you are right, they did mess up the install. Also, it was really cold when the did it. I haven't washed the car since though... To give them credit, they told me in the begining that they didn't like the pre-cut stuff I brought with me, and they usually cut the overlays from the bulk Lamin-X material they got.
 

·
Registered
Joined
·
2,125 Posts
^ should of did what they said since you were paying them to put it on.

I helped with my friends ms3 cutouts and they suck.

I will never buy precut tint
 

·
Registered
Joined
·
1,998 Posts
shitty install....they didnt stretch it enough....i installed my ebay taillight tint a year ago and it still looks perfect but i installed it in the summer....doing it in the winter will cause problems
 

·
Registered
Joined
·
1,031 Posts
Discussion Starter · #11 ·
shitty install....they didnt stretch it enough....
Yup, that's what I figured out, the bad stretching and the cold. Well, TY to all who contibuted to this thread, I am gonna post some follow-up pics on Tuesday (hopefully).
 

·
Registered
Joined
·
6,542 Posts
sweet. keep us informed.

I made your mistake too fyi.... I first bought pre-cut's, they sucked, then I had a shop do them without using the pre-cut's and it's perfect.
 
1 - 15 of 15 Posts
Top