8th Generation Honda Civic Forum banner
21 - 31 of 31 Posts

· Registered
Joined
·
312 Posts
Discussion Starter · #21 · (Edited)
ok, I just had the guides and the chain replaced and my mechanic is now saying that the noise is more apparent on idle????? FML... so his keeping the car to do more indepth dianogstic. stay tuned
Now is the last step 1000$ later my mechanic is asking for the skunk2 camshaft boxes the cams came in to see if its one of the bad batches that where sold... I cant wait, cause im swapping the tsx cams back and if this is the case no more excuses or possibilities why im having issues the monkeys ass is out...
 

· Registered
Joined
·
312 Posts
Discussion Starter · #24 ·
wow man, with all that cost you spent you could have just got IPS cams and used the OEM tensioner.. there goes Skunk2 screwing over another customer.
yeah I found out the hard way, my whole ride is skunk2


1. S2 suspension, before i bought i called and ask about the ride review how everyone whos had it says its too bouncy. I called directly skunk2 and they said no never heard any complaints.

2. S2 rear camber arms less than 6 months or so the bushings shred from v1 and called for replacement they sudgested wait or buy V2 with poly bushings

3. S2 stage 1 cams, lock pin that inserts into the cam gear gets pushed in after installing while driving car stalls, then throw offs my timing. Called S2 direct and they said it was due to bad installation and i would need to by another intake cam for 300+. recieved replacement then went through 2 oem tentioners and 1 hybrid.. still fixing problem 4000+ later, FML

YES, I'm done:deadhorse:
 

· Registered
Joined
·
1,276 Posts
do you have the updated version of the chain tensioner? i just upgraded my 2.4 build and I had the hybrid chain tensioner and I contacted them and they stated they had revised it and sent me a new one in exchange
 

· Registered
Joined
·
312 Posts
Discussion Starter · #26 ·
do you have the updated version of the chain tensioner? i just upgraded my 2.4 build and I had the hybrid chain tensioner and I contacted them and they stated they had revised it and sent me a new one in exchange
yes I do, I am so done working on internal motor work unless im doing it myself cause ever since i have dealt with other mechanics and Companies with their shity products no one has ever stepped up and replace their defective products except for Hybrid Racing.
 

· Registered
Joined
·
312 Posts
Discussion Starter · #27 ·
fantastic update so i decided to take off my boomba mounts the upper mount and removed skunk2 stage 1 cams along with my vibrant header and fwala!!! no more noise. not really sure if it was the crappy s2 cams since i spent over 1000 making sure everything was fine. so my car pretty much stock now and working great. i have learn a great lesson, NEVER BUY PARTS FROM SKUNK 2 RACING, HYBRID TEAM THANK YOUR FOR ALL YOUR HELP!!!!!!
1. i removed the s2 suspension
2. removed header
3. removed S2 cams
4. checked guides and replaced the chain
5. replaced tensioner 3 times
6. removed upper boomba mounts
 

· Registered
Joined
·
166 Posts
pinoysi06 I installed my s2s1 cams and chased a noise which I thought was tct for a while one day I noticed soot around my header at the head , tightened it and noise has been gone along with soot. did not make the noise until the aggressive cam installed , one stud at the end of the header was loose in the head and the bolt had tightened to the stud at the midway shelf point on the stud but did not secure the header. its worth a look , I have had no noise since and with the hybrid you can check anytime and there is no slack in the chain. the hybrid tct is a beast the s2 tct is due out in jan. I would go with the hybrid
 

· Registered
Joined
·
2 Posts
just read the email from hybrid, Apparently the chain tensioner they replaced which i sent back has no issues. hybrid is sudgesting to have my motor further diagnosed. The problem my mechanic said was the HB chain tensioner failed due to side to side motion, HYbrid tech said "they put it on a testing rig and the teeth and the motion is ok", WTF...

i am going to have my chain cover removed and checked to see if the guides are ok, hopefully this will tell me what the problem is. The noise is coming from the side where the cam gears are not where the chain is after the the head job was completed.
Change your mechanic, I've been using Hybrid Racing V1 tensioner for almost 10 years in fully built K24 turbo charge motor reving to 9500 built by me with no issues. Ferrea 110 lbs seat pressure valve springs & Skunk2 stg 3 cams back then, currently using ULTRA 4 with TODA Racing HD Timing Chain.
 
21 - 31 of 31 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top