8th Generation Honda Civic Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
ok so i have a 2007 si sedan and lately i've been having a problem when i turn the steering wheel completely and start to go my stereo shuts off and i loose power from the steering wheels. also when im at a stop and turn my steering wheel all the way to the left or right it does the same thing it has shut down once on me before but turn right back on by it self in less then 5 sec. Has anyone had this issue before? my mods are Skunk2 alpha headers, 76mm skunk2 cat-back, boomba torque mounts, injen coldair, Flashpro, and lowered on ksport kontrol pro.
 

·
Registered
Joined
·
1 Posts
Having the same problem, car is a 2008 Si coupe. Nothing modified under the hood, only apexi exhaust in the back. Electronics are all stock, no aftermarket head unit/navi/amps. 52k miles & I've been the owner since 30k miles.

Seems like the car is experiencing a voltage drop when the steering is engaged, causing it to shut off. I have narrowed down the conditions when this happens & I can recreate the problem at will now. I can sit in car with the engine on, car is not moving, transmission in neutral and turn the steering wheel suddenly either almost completely left or right. The power steering will stiffen and my stock radio/navi will turn off. Steering immediately comes back and the radio restarts. Engine does not stall, but sounds as if it is about to for a split second. Noticed this first when making 90 degree turns at low speed about 2 weeks ago.

Poster above had good idea; will start with battery, alternator, and possibly grounds and go from there.
 

·
Registered
Joined
·
69 Posts
Discussion Starter #5
Yeah I will be doing the same. I wonder how many others have had this problem also at first I thought it was just me
 

·
Registered
Joined
·
2,041 Posts
Guys you have Si's they have EPS(electric power steering), so whenever you turn the wheel it puts a load on the electrical system. Either the battery or alternator(or both) are on it's way out.
 

·
Registered
Joined
·
211 Posts
ive been having the same problem as well, havent narrowed it down to what exactly causes it. but sometimes when im driving and when im at a stop, the idle drops low and the radio will shut off then come back on. i replaced my battery about 5 months ago with a new one, so my guess from what ive been reading is my alternator. how do i go about checking the alternator?
 

·
Registered
Joined
·
896 Posts
I have a similar problem also, but my power steering doesn't drop. My radio just turns off and on as well as my lights. I also replaced my OEM battery about 4 months ago with an optimum yellow top.
 

·
Registered
Joined
·
202 Posts
Mine was acting very similar. I ended up replacing my battery, only had 35CCA and it seemed to fix it. Or at least it hasn't happened since then.

It was happening on and off for about a year, but recently it was happening more often. Even 2 or 3 times a day. It was funny because the car started perfectly everytime, even throughout the winter. However when I tested it at work it was only rated at 35cca, swapped the battery and fine since.
 

·
Registered
Joined
·
906 Posts
Bringing back a dead post but...

I've been having this same problem. Mine typically a happens when making a full lock turn or when the A/C compressor kicks on at idle.

My battery is currently dropped to the subframe.. Looks like its time for a password frame and a new battery
 

·
Registered
Joined
·
514 Posts
any updates on this problem? i've had this too, checked the battery and its okay. its kinda scary to lose your power steering... happened to me while on the freeway.. while swerving out of the way of somebody who was about to hit me.
 

·
Registered
Joined
·
892 Posts
Need to bring this thread back!! Ive recently used flashpro and now ever time I turn my wheel to the most the radio shuts off, and when my windows are closed I can pull up on the switches and radio will turn off and on willingly...just had a new battery install last year so I need to check my alternator but dont know how to do that. Let me know guys!!!
 

·
Does this do anything?
Joined
·
2,716 Posts
To have the alternator tested drive to an auto parts store and ask them to test the alternator. Or take the alternator off and have them test it on a bench tester. The fact that this seems to come about right after flashpro makes me think it is something else though, like setting the idle speed too low, so the alternator isn't charging at idle. Or a problem with the ELD that arises from flashing the ecm.
 
1 - 20 of 28 Posts
Top