8th Generation Honda Civic Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
661 Posts
Discussion Starter #1
several people have posted their complains about the suspension popping and creaking(TBS). But has anyone of you guys got fixed their problem already? tell the story so we could get some ideas what was the real problem and how did they fixed it!
 

·
Registered
Joined
·
1,808 Posts
I had the bumped stop replaced in the TSB.

First thoughts were that it was completely gone. I could have sworn I heard it again, but the more i think about it I was just be being paranoid.

I haven't heard the POP noise for a long time, I think the TSB remedied it for me.
 

·
Registered
Joined
·
202 Posts
i had ths tsb fix done as well and it has worked so far, i havent heard any noise in the 500 miles i put on my car since it was done. i have an 07 fa5 and i still had the problem right off the showroom floor
 

·
Registered
Joined
·
661 Posts
Discussion Starter #4
beauhance said:
i had ths tsb fix done as well and it has worked so far, i havent heard any noise in the 500 miles i put on my car since it was done. i have an 07 fa5 and i still had the problem right off the showroom floor
did they replaced the bump stop too just like the others?
 

·
Registered
Joined
·
2,287 Posts
i had it check yesterday. they told me they going to order the parts for it. so i have to come back next time. i told them about the tsb they gave me all this bs about there is no tsb it just only the recall. i keep giving them the lecture then he just said ill have the tech. check it out. later i got a call that they already order the part for it already.
 

·
Registered
Joined
·
94 Posts
my dealer replaced both my front strut assemblys for the popping noise, mine is a 2007 2door which is out of vin range for the tsb but the pop noise is still there and is louder but the car handles better and turns faster than my origunals i took it back to the dealer and was told this is a product characteristic, only happens when car is on and turning wheel when car sits over 10 min and not moving then is fine when driving
 

·
Registered
Joined
·
661 Posts
Discussion Starter #9
i might try switching to eibach prokit, it might solve the problem, cuz i just got this problem after i put the teins stech. then if didnt resolved the problem i will take it to the dealer, i dont really like the feel of the teins stech anyway!
 

·
Registered
Joined
·
202 Posts
yeah they just replaced the bumpstop and associated hardware, all that happens is that the bumpstop binds up and dosent sit properly, my car wasnt in the vin range for the tsb but i told them i wanted it done and they did it and it worked
 

·
Registered
Joined
·
661 Posts
Discussion Starter #11
beauhance said:
yeah they just replaced the bumpstop and associated hardware, all that happens is that the bumpstop binds up and dosent sit properly, my car wasnt in the vin range for the tsb but i told them i wanted it done and they did it and it worked
is your car lowered with aftermarket springs?
 
1 - 11 of 11 Posts
Top