8th Generation Honda Civic Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter #1
I have a 4 door ex with navi and have been patiently waiting to do my stereo install. I had gotten my alpine amps along time ago and had my alpine speakers that I want to use for some time now. The piece that I have been needing to place between my factory navi and alpine amps has been advertised for almot 1.5yrs now in the alpine catalog. My Alpine PXE-H650 finally came today and I will be picking it up next wk, now I can finally start laying out my stereo install. I will post some pics of the unit when I finally get it in my hand. Alpine sure does take there time on releasing products that they advertise.
 

·
Registered
Joined
·
134 Posts
I've read through the PXE-H650 manual and it looks great. The only downside is you have to use the supplied remote to control your volume. I'm anxious to hear about your results. I've been considering this unit versus the CDA-9887 HU, which also has the Audyssey MultEQ cabin equalization.
 

·
Registered
Joined
·
158 Posts
The EX with factory NAV is listed as 340 watts on the Honda site so that indicates the factory amp and the balanced audio HU. All the 340 watt systems use the factory amp. The LX and standard audio 160-170 watt systems have a speaker level output HU that can be connected like your system. I’m not sure how the earlier models came equipped, so I go by the power ratings of the systems to determine the system type. If he has the 170 watt package his Alpine will work fine.

jeff
 

·
Registered
Joined
·
114 Posts
Discussion Starter #5
I don not have the factory amp in my car. The system is only rated at 160watt, as it does not have the premium sound system like the si.
 

·
Registered
Joined
·
114 Posts
Discussion Starter #6


I have all my components in hand to do the stereo now. I have 2 sets of alpine 6562 component speaker sets, the alpine pxe-h650, one alpine MRP-M450 amp for the alpine 12" subwoofer, and one alpine MRP-F450 4 channel amp for the components. I do have an alpine MRV-F400 4 channel amp and a alpine MRV-T500 2 channel amp. I haven't decided which pair of amps to use yet.
 

·
Registered
Joined
·
41 Posts
I've never seen those Alpine component speakers....curious when they were originally available.

I seriously considered using the PXE-H650, but decided instead that I will (most likely) use the 9887+Imprint sound manager. Not sure when I'll get the system started though....
 

·
Registered
Joined
·
114 Posts
Discussion Starter #8
These speakers were available back in 94, they were the best they had out at the time. I just happen to have 4 sets of these brand new in the box. They were so good that on top of the original 3 sets I purchased, I got another 4 pair before they were discontinued for later projects. The only reason I went with the alpine pxe h650 is due to having factory navigation, or I would have gotten a different head unit and went in another direction with the system.
 

·
Registered
Joined
·
41 Posts
now I am curious as to what those Alpine speakers sound like....

I looked into factory integration using the H650, but decided to instead go with an aftermarket headunit. The H650 does everything I want except direct iPod integration, otherwise I would be using it, too.
In addition to the headunit, I'm also planning to use the PDX amps, and the Focal K2Ps and Alumapro MX sub from my old Civic.
 
1 - 9 of 9 Posts
Top