8th Generation Honda Civic Forum banner

21 - 40 of 62 Posts

·
Registered
Joined
·
342 Posts
Same here, no problems at all... Very simple to do. Took me like 1 hour tops but that's because I was taking breaks. I'm very happy with it...
 

·
Registered
Joined
·
432 Posts
I'm pissed because skunk2 says it can be ran without flash pro but yet I'm having a cel already. Just installed mine last night. Any remedies without flash pro ?
Yup u need fp that y I got it also but with out fp your car crazy lean so I just got fp and did a dyno tune now its runs great
 

·
Registered
Joined
·
170 Posts
Did anyone else have a big problem with the new ecu bracket? It seemed like the whole bracket was off as far as lining up the holes to put the ecu on. I ended up having to zip tie them instead of bolting it back on because of how off it was. And I'm not sure about this decision but instead of having the resevoir tank underneath everything. I zip tied it up on the side above the actual intake. I also had a problem putting the heat shield that goes under the cowl back. Decided not to put it back on would I be running into a problem without that heat shield?
 

·
Registered
Joined
·
445 Posts
Installed mine today on a 2006 FG2. A couple of things that were skimmed over in the included instructions:
- I had hell getting the ecu plugs over to the new ECU location. I ended up having to unbolt the brake fluid reservoir and passing the harness wire on the left side of it. I also had to remove a few harness wire clips. Unbolting the reservoir also aided in getting to the OEM Ecu bracket bolt.
- Access the lower battery tray bolts from under the car.
- The rotational position of the nippled elbow is critical for fitment. I wish there were more of a an description or guide regarding the intended alignment of this section. I couldn't tell if I drilled the hole wrong, had the bracket in the wrong orientation, or had the elbow in the wrong orientation. The sections didn't exactly line up easily.
 

·
Registered
Joined
·
13 Posts
did the install this morning, every thing went good. the only problem I have now is when im driving high way speeds I hear a weird noise, sounds like the intake might be rattling, or something. cant really figure out where its coming from. just wanted to know if any one else had this issue? thanks
 

·
Administrator
Joined
·
45,045 Posts
did the install this morning, every thing went good. the only problem I have now is when im driving high way speeds I hear a weird noise, sounds like the intake might be rattling, or something. cant really figure out where its coming from. just wanted to know if any one else had this issue? thanks
You didn't tuck the radiator cover into the grille.
 

·
Registered
Joined
·
7 Posts
that was one of the most intense installs for an intake i have ever seen. kudos for taking the time to do this nicely detailed diy
 
21 - 40 of 62 Posts
Top