8th Generation Honda Civic Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello new member here! I’m working on a 2009 civic r18, it has a misfire but no check engine light. I already checked the following
Spark plugs were new not long ago
Coils pulled one at a time and seem to be working
Compression check
Pulled fuel injector plug one at a time and seemed good
Checked for vacuum leaks
I pulled egr plug while running and no change and check engine light doesn’t come on? I assume it should, sometimes it takes a while to start thinking it’s fuel related but don’t have a fuel pressure tester. I have a code reader and can read live data any test I could do to narrow it down??
 

·
Registered
Joined
·
208 Posts
What spark plugs were used? Lots of copy cat Chinese plugs out there. I typically only use OEM parts if it bolts to the motor. Has not failed me when using this approach on Hondas.

Mentioned it cranks longer... pull the rear seat out and remove the fuel pump access cover. If the pumps struggling it will burn the wire connections at the connector to the fuel tank. Only valid repair is to replace the whole fuel pump and sender assembly. I did this on a 2008 that exhibited the same issues at about 160K miles. Were well over 200K now and still running.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Update tested fuel pressure was 58 psi and held pressure while shut off for at least 30 mins. Checked timing and it’s good, check valve lash few exhaust valves were tight so corrected them. Seems to run good cold but after a few minutes it will start to miss, I plugged in code reader and notice that egr wasn’t reading anything, any test I can do to egr valve? Any help would be appreciated!
 

·
Registered
Joined
·
208 Posts
I don’t know if your scanner has the ability to run a test. If your getting a CEL code for EGR then I’d remove it and clean it up or replace it. Having them stick open is real and will make it miss like that.

If no CEL it’s still possible the valve is hanging but the switch inside thinks it’s closed.



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
No cel on and egr reads 0 on code reader I unplugged egr and runs the same was thinking about removing it but don’t have a new gasket here, would I need one?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Yes gonna remove it on my code reader there is 2 readings for egr, both 0. On one you can command egr no change other one says egr error. Then I went in to ready test and it had a x by cat,evap,egr and 02s think it’s all related to egr?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Update removed the egr valve and valve was stuck shut, I got it free up and cleaned install and no miss at idle! Gonna take it for a drive and see what’s it like
 

·
Registered
Joined
·
208 Posts
Good to hear. Good thing is it’s so easy to access. Right on top and simple as can be.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
137 Posts
You might start looking around for one at a salvage yard. My experience over the years is that once they start sticking, they will stick again. But then again, now that you know what it is, what have you got to lose by waiting.

Good to hear some good news.
 
1 - 10 of 10 Posts
Top