8th Generation Honda Civic Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter · #1 ·
I have a 2006 Honda civic Ex 4Dr with 204,000 miles on it. I had the charcoal canister replaced along with two sensors back there and the purge valve replaced as well. A week later, P0496 came up and anytime I fill my car up with any amount of gas my car won't start up whatsoever. It cranks, I have power, and if it does start... My car will shake, I can see my RPM's dropping off, and then the engine starts shutting down. What I'll do is press on the gas pedal while starting the car, then keep the RPM's around 1,000 then after a min or two the car will start fine and yes, drive perfectly.
 

·
Registered
Joined
·
226 Posts
Yes verify fuel pump. I had the electrical connections into the tank get burnt up which caused an intermittent. Verify the wiring at the pump. Had to replace whole assembly but it’s been fine for last 80K miles since.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #4 ·
When did you replace your purge valve? If your sure its not that I would look into the fuel pump next.
I replaced it a week before the problem started to happen, but I don’t think a brand new aftermarket part would cause a problem. But who knows, I’m still learning.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #5 ·
Yes verify fuel pump. I had the electrical connections into the tank get burnt up which caused an intermittent. Verify the wiring at the pump. Had to replace whole assembly but it’s been fine for last 80K miles since.


Sent from my iPad using Tapatalk
I’m guessing it’s that because everything else is ok, new spark plugs and air filter. No leaks anywhere, had leaks checked out twice just in case. Plus, whenever I use cruise control P0171 pops up. Then goes away when I don’t use it. When I use it again, it’ll come back.
 

·
Registered
Joined
·
226 Posts
Easy enough to get to. Just unbolt rear seat bracket and cover plate. You can see wiring harness on top. If burnt you will know!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #7 ·
Update,
I had a brand new fuel pump assembly put in my car with new gaskets and everything. Been driving for a few days, with cruise control too. It looks like I'm not getting any codes, but what do you know. When I go to put gas in my car, my car acts up and won't start up. It'll even turn on then shut right off after 3 seconds. Even when I get it to stay on, by pressing the gas and keeping it lightly pressed. It shut off once while driving. This is so weird. I'm beginning to think it might be my timing chain. My car is at 206,000 miles now.
 

·
Registered
Joined
·
18 Posts
My guess would be that your new purge valve is faulty. Yes, new parts can be bad.

You could try holding the gas pedal to the floor, while cranking, when it won't start... this should cause the ECU to turn the injectors off because you are trying to clear a "flood" situation, which is essentially what is happening if the purge valve is flooding the engine with gasoline vapor.

The other option would be to block off the line going to the purge valve with a rubber cap or something and see if this fixes your issue.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #9 ·
Ok, thank you so much for the read and helping me out. I should have the warranty for this part I got from my personal mechanic. I will try to get the purge valve replace replace.
 

·
Registered
Joined
·
18 Posts
Ok, thank you so much for the read and helping me out. I should have the warranty for this part I got from my personal mechanic. I will try to get the purge valve replace replace.
I would test it as I described and see what happens before condemning the purge valve.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #11 ·
I have tested it, it’s literally the only way to start my car. By pressing the pedal down to the floor. I’m looking for this part and I’m not sure to go OEM or a doorman one for it
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #13 ·
Alright, so currently I don’t have a job so I opted for a replacement part on ebay for 19.99. The purge valve. So far so good, I filled up on gas and my car started up perfectly. It’s been two weeks already and no problems :)
 
1 - 14 of 14 Posts
Top