8th Generation Honda Civic Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
1,016 Posts
Discussion Starter #1
So I've got the CTSC stg2. I'm in CO so my boost is a little lower than usual.

However, I notice this thing sucks oil like a madman. I run through a quart every 1-1.5k miles. Also, on really cold nights if my car is parked outside, it has trouble starting. I have to try it a few times, wait 5 mins, and then try again and it usually starts. I'm not sure if it's related to the oil burning issue. Battery is brand new btw.

When I first got it, I was hitting 6psi peak, now I'm pretty stable at 4 psi. Not sure why the decrease.

I also notice a white/blue smoke coming out at WOT.

Another issue is when I first had the SC, I was averaging about 28mpg. I notice I'm only getting roughly 23-24mpg now.

I'm thinking its getting out of tune? I'm not sure how that would happen as I haven't added or changed anything since Vit tuned it.

I've had the SC for about 2 years now and I'd say about 20-30k miles?

Anyone have any similar problems or suggestions?
 

·
Registered
Joined
·
663 Posts
Your motor is weak bud. It's had better days, that's all. Compression is at an all-time low and I'm sure it's because you're rings are tired of your supercharger.
 

·
Registered
Joined
·
663 Posts
Yeah, running rich is going to give you trouble starting, but also, a low compression cylinder will as well. If that compression isn't there when that spark fires the fuel, that piston ain't gonna give a f.ck. It's not going push down and keep the rest going in motion. Your rings have probably seen better days.
 

·
Registered
Joined
·
663 Posts
It's not uncommon. But I hate to diagnose this over the internet. I mean, can you take it to a tuner and have them give you their honest opinion. You can always call them too and explain. You can call any Honda tuner across the country and ask. Otherwise, if they want to see it, take it to any tuner locally. Maybe Vit knows and can shine on this.
 

·
Registered
Joined
·
1,016 Posts
Discussion Starter #8
It's not uncommon. But I hate to diagnose this over the internet. I mean, can you take it to a tuner and have them give you their honest opinion. You can always call them too and explain. You can call any Honda tuner across the country and ask. Otherwise, if they want to see it, take it to any tuner locally. Maybe Vit knows and can shine on this.
Alright. Yea I was hoping Vit might see this or I'll contact him directly.

I also plan on calling my local honda tuner to see what he thinks. There are compression tests that can be done to verify what you're thinking right?
 

·
Registered
Joined
·
663 Posts
Oh gosh yeah, just do it yourself. Go get a compression test from Autozone. It's free. Well I think you have to give them money, but they give it back when you're done. Pulll the spark plug and turn it over and there's your compression. Do that 3 more times and you have a full test done. Then after that, we'll go into something else called a wet test.
 

·
Registered
Joined
·
1,016 Posts
Discussion Starter #10
Oh gosh yeah, just do it yourself. Go get a compression test from Autozone. It's free. Well I think you have to give them money, but they give it back when you're done. Pulll the spark plug and turn it over and there's your compression. Do that 3 more times and you have a full test done. Then after that, we'll go into something else called a wet test.
LOL I only read the first half of that sentence. "It's free. Well I think you have to give them money."

That sounds like a good plan of attack. I think I'll have some time over the weekend to give it a shot. Appreciate the help.
 

·
Premium Member
Joined
·
5,329 Posts
Valve adjustment wouldn't hurt. In the mean time I would check your logs and see how your primary o2 sensor is doing unless your running a wideband :shrug:
 

·
Registered
Joined
·
1,016 Posts
Discussion Starter #13
Valve adjustment wouldn't hurt. In the mean time I would check your logs and see how your primary o2 sensor is doing unless your running a wideband :shrug:
Yea I'm running the AEM wideband. I should get a new log though, although I don't know how to read them.

My car knowledge doesn't extend beyond bolt ons and basic CTSC stuff. Engine internals and tuning is Russian to me only because that's where you can really break stuff and I get scared doing it myself.

Hahah. Hell yeah. You like that?

But yeah, whatever you do, make sure you report back and let us know everything.
Definitely will, thanks.
 

·
Registered
Joined
·
1,016 Posts
Discussion Starter #14
Hey guys I finally got around to doing the compression tests. Turns out all cylinders were all within 1 unit of each other around 140.

My guy helping me thought it could be a bad tune, people on the subie forums think it's a whole slew of problems such as a bad head?, valve guides, etc.

I'm not sure what to do next.
 

·
Registered
Joined
·
98 Posts
Hey guys I finally got around to doing the compression tests. Turns out all cylinders were all within 1 unit of each other around 140.

My guy helping me thought it could be a bad tune, people on the subie forums think it's a whole slew of problems such as a bad head?, valve guides, etc.

I'm not sure what to do next.
Did you contact Vit?
 

·
Registered
Joined
·
4,608 Posts
Hey guys I finally got around to doing the compression tests. Turns out all cylinders were all within 1 unit of each other around 140.

My guy helping me thought it could be a bad tune, people on the subie forums think it's a whole slew of problems such as a bad head?, valve guides, etc.

I'm not sure what to do next.
The subie guys think that because everything on those motors break LOL
 

·
Registered
Joined
·
1,016 Posts
Discussion Starter #17 (Edited)
Did you contact Vit?
i did and gave him some logs. He said everything looks good from the logs and nothing screams out "problem". However it still doesnt explain the decreased boost / mpg / massive oil consumption and smoke clouds...

I've got a dyno scheduled with a local tuner and they're gonna see what they can find.

The subie guys think that because everything on those motors break LOL
That's kind of what I was thinking. I'm like, you know its a K20 right? But then again they have knowledge of the symptoms so I can't help but appreciate their inputs.
 

·
Registered
Joined
·
1,403 Posts
I would and see any oil in intake manifold or throttle body, if oil in intake and throttle body you will need new valve seals, Also I would check pcv valve, after a while they do go bad and it's related to oil consumption, blue smoke, indicates rings and if it's white run lean.

Edit: you mentioned you got sc for about 2 years, drop another low mileage k20z3 will solve your problem once for all!
 

·
Registered
Joined
·
1,016 Posts
Discussion Starter #19
After the dyno everything checked out fine. Vit said my primary O2 sensor was reading way off from what they saw at the dyno so I replaced that.

The dyno was also getting a solid 7.5psi peak boost where my gauge was only reading 4 so I'm thinking the gauge is just either not calibrated or getting inaccurate. I'm not sure.

I was getting a little bit of oil in the mani/TB but I think it's just blowback from lack of using catchcan / breather.

Everything's taken apart at the moment since I'm retrofitting my headlights at the same time. I'm hoping once I get it back on the road I'll see some promising results.

@Flyk20z3 - How does one check the pcv valve? I was planning on just connecting my VC + PCV to a breather can and call it good.
 

·
Registered
Joined
·
331 Posts
Hey guys I finally got around to doing the compression tests. Turns out all cylinders were all within 1 unit of each other around 140.

My guy helping me thought it could be a bad tune, people on the subie forums think it's a whole slew of problems such as a bad head?, valve guides, etc.

I'm not sure what to do next.
Well there is your problem!!!:facepalm: your cylinder pressure is only 140psi??? Well , that is roughly 8.1.1 compression in the cyl these motors are 11.1.1 compression ratio!!! U are roughly 3 points low in each cyl translation , your motor is worn! :eek:hsnap: time to freshen it up:vtec:
 
1 - 20 of 25 Posts
Top