8th Generation Honda Civic Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So... I have an 08 Civic LX that doesn't seem to be charging properly. When I start the car, I'm shown about 14v from the battery, the HUD Light doesn't freak out. Then after about 5 minutes it suddenly drops down to about 11v - 12v, my battery light kicks on sometime in between there, and the charge slowly starts ticking down. Once the voltage reaches about 11.5v, something will trigger in the car to bring it back up to 13v, but it will continue to tick down until it reaches 11.5v, starting the loop over. I know for certain that the battery is good, I noticed the fuse to the alternator was blown, so I replaced that. When that didn't do the trick, I decided to replace the alternator with a new one (same with the timing chain that was wearing out), but none of that worked. I looked at several forums where people had similar problems and tried a few workarounds, but the battery did the same thing every time. At this point, I'm running out of options, and I'm trying to avoid getting a mechanic to work on it because money is tight. I was hoping the vast culture of the internet might have some good ideas. 😔
 

·
Registered
Joined
·
206 Posts
What brand of replacement alternator did you use. Lots of horror stories with non-Denso parts. The fuse blown concerns me though. Sure you have good clean power and ground connections? Engine ground to frame/body is important here


Sent from my iPad using Tapatalk
 
1 - 2 of 2 Posts
Top