8th Generation Honda Civic Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter · #1 ·
So i have had my car for allmost a year now. and its a 2006 Si coupe. Not sure if that matters but heres the problem:

Every once in a while the driver airbag light turns on. The first time it happened i took it to honda and they said there was something wrong with the seatbelt sensor. (fixed under warrenty)

Now about 2-3 months later i have been getting the light again. But my car is a 2006 so the warrenty is up. Im not really sure what the problem is because the light stays on for about a day then turns off for a little bit then turns back on when it feels like it.

Car is 100% stock

Anyone else have these problems or have an idea what i should do?
 

·
Acorns!
Joined
·
17,760 Posts
is anyone else in the car with you - passenger seat? If a person is in the seat, and they lean towards the door/window - the sensor in the seat knows this and stops the side airbags from deploying. That light will come on in those instances. If they sit back normal in the seat, the light will go off.

If it's literally something in your seatbelt, then you obviously may need to have it looked at. I don't know when you bought your car, but you have 3 full years from the date of purchase on warranty. The SI's were out in like Dec 2005. I don't know how early you bought your car...
 

·
Pillar of Objectivity
Joined
·
8,915 Posts
Happened to me for months.

Finally got the dealer to catch it while it was on. My car that has never been in an accident had a faulty passenger seat airbag. They fixed it.

Two days later, it was back on again. This time, the passenger front airbag was faulty.
 

·
Registered
Joined
·
185 Posts
Discussion Starter · #6 ·
mine does the same thing the airbag light shows up on the cluster not on the dash piece beside the radio...

it will go away after a little while but it shows up everyonce in a while
Yeah...exactly my problem, it sometimes happends when my car looses traction, but also sometimes when ever im just driving normal. I have no clue whats wrong. My cars out of warrenty so i dont feel like wasting $85 to just "findout" whats wrong with the car.
 

·
Registered
Joined
·
360 Posts
Hate to revisit and restart such an old thread but I have the solution XD. It has to do with the connection for the passenger air bag being caught and slightly unplugged. It is located under the passenger seat a little ways back and if I remember is a yellow plug. My solution was that I ziptied it together so it wouldn't come loose and then ziptied it so it wouldn't be tugged on by the seat moving forward or backward.
 

·
Registered
Joined
·
360 Posts
So for you Men, I'd recommend checking all of your connections for the airbags on your car (Once the car is off of course) and make sure there isnt a known issue with a bad connection on your specific car. This was common on ours and happened because of the passenger side connection. Sometimes a code reader actually says the location of the fault ie passenger srs bag circuit open.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top