Car lost of power - 8th Generation Honda Civic Forum
8thCivic.com

Go Back   8th Generation Honda Civic Forum > Community Help Section > Community Help

Reply
 
LinkBack Thread Tools Display Modes
Old 06-16-2018, 10:47 PM   #1 (permalink)
Junior Member
 
Williamsi's Avatar
 
Join Date: Jun 2018
Posts: 1
Williamsi has their car in neutral right now
iTrader: 0 reviews
Car lost of power

Hi, I’m new on here. I just got a civic si 2007 si the car has a greedy turbo kit installed. Upon receiving car, it had a great boost. I’ve noticed Recently that the car lost power. First gear struggles to rev to 4K on rpm, rev indicator stopped working. I changed the transmission fluid and engine oil with filter last week. I’ve also noticed another issue when slowing down to a stop on a gear the car makes a squealing noise, however when I slow down on neutral it doesn’t make this noise! Gears shift smoothly, just very low power and wondering if anyone can give me ideas of what could be the problem. Any advice would be appreciated. Thank you.

Best regards William.

Williamsi is offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 8th Generation Honda Civic Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Diary of a Touge Newb WolfSi Garage 54 06-20-2019 11:08 AM
Ayy, I just bought my dream car! MilkMan71 Introduction & Pictures 0 05-28-2018 11:17 PM
Car won't start, Starter issue? Bad battery? joenobodyyet Mechanical Problems & Technical Chat 2 02-05-2018 12:05 PM
DIY - Alarm and Remote Start 8th civic verbstyler I.C.E., Electrical, Security, & Navigation 12 01-12-2018 10:43 PM
Car lost power and died wcsmoot_06 Mechanical Problems & Technical Chat 2 02-13-2017 06:42 AM


All times are GMT -4. The time now is 01:40 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
copyright 8thcivic.com - all rights reserved