Horn doesn't work - 8th Generation Honda Civic Forum
8thCivic.com

Go Back   8th Generation Honda Civic Forum > Model Specific Civic Information > Civic Coupe And Sedan

Reply
 
LinkBack Thread Tools Display Modes
Old 11-16-2015, 08:48 AM   #1 (permalink)
Senior Member
 
Join Date: Feb 2011
Location: TEXAS
Posts: 111
bubbe2005 just put it into 1st gear on 8thcivic
iTrader: 0 reviews
Horn doesn't work

My horn doesn't work. It blew the last time we encountered a bad thunderstorm.

When the horn doesn't work; could it be the fuse or the actual horn or something else?

I just wanted your take on it. I wanted to replace the fuse this past weekend but it was raining. So I'll try to do it this weekend.

But I will also be replacing the horn to the Accord horn later down the line. I just need the horn to work to pass my TX state inspection before I can then be able to renew my vehicle registration.

bubbe2005 is offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-16-2015, 11:17 AM   #2 (permalink)
Senior Member
 
CraigW's Avatar
 
Join Date: Mar 2010
Location: OH
Posts: 2,501
CraigW just put it into 1st gear on 8thcivic
iTrader: 0 reviews
Check brake lights operation & listen for clicking from under dash when attempting horn.

CraigW is online now   Reply With Quote Quick reply to this message
Old 11-16-2015, 04:00 PM   #3 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Oak Lawn il
Posts: 559
David Malcolm
Captaincrazydavey just put it into 1st gear on 8thcivic
iTrader: 0 reviews
It literally can be anything from the switch to the horn and the wiring in between. I'd suggest checking the fuse first and if that's fine check for power and ground at the horn.
Captaincrazydavey is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-16-2015, 06:35 PM   #4 (permalink)
Senior Member
 
2poler's Avatar
 
Join Date: Mar 2015
Location: Chicago
Posts: 199
Joe
2poler just put it into 1st gear on 8thcivic
iTrader: 0 reviews
My fuse blew twice when installing my fog lights? Replaced and going strong almost 6 months.
2poler is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 8th Generation Honda Civic Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade horn doesn't work properly after rain Bigjay1six1 Mechanical Problems & Technical Chat 5 07-09-2010 02:58 AM
My horn doesnt work! SunRfr08 Mechanical Problems & Technical Chat 11 05-02-2009 06:03 AM
My horn doesn't work sookie626 Mechanical Problems & Technical Chat 11 09-01-2008 09:30 PM
Horn doesn't work geminon2k7 Introduction & Pictures 8 09-05-2007 09:19 AM
messed up! installed fiamm horn and now my temp reading in dash doesn't work Stealthcivic Mechanical Problems & Technical Chat 15 08-26-2007 10:25 AM


All times are GMT -4. The time now is 10:05 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
copyright 8thcivic.com - all rights reserved