Throttle bodies for the supercharged (and everyone else) - Page 7 - 8th Generation Honda Civic Forum
8thCivic.com

Go Back   8th Generation Honda Civic Forum > Honda Civic Technical > Forced Induction And Nitrous > Supercharging

Reply
 
LinkBack Thread Tools Display Modes
Old 10-08-2012, 09:59 PM   #121 (permalink)
Senior Member
 
Join Date: Mar 2011
Posts: 316
I'm planning on buying the J37 for my rbc manifold. Can I just run the stock intake tube with this TB for a while until I get flashpro and a 3.5 intake? Thanks.
jwco5.3 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-08-2012, 10:05 PM   #122 (permalink)
Senior Member
 
dodtbdm's Avatar
 
Join Date: May 2010
Location: lost begas
Posts: 9,846
artwilight
I think you should get flashpro first.
dodtbdm is offline   Reply With Quote Quick reply to this message
Old 10-09-2012, 01:34 AM   #123 (permalink)
there is no spoon

 
Join Date: May 2006
Posts: 16,805
Don't run the J37 without FlashPro.
__________________
becauseHONDA™
mucter is offline   Reply With Quote Quick reply to this message
Old 10-09-2012, 09:27 PM   #124 (permalink)
Senior Member
 
Join Date: Mar 2011
Posts: 316
Will a base tune suffice for the J37? Obviously not long term, but I'm not tunning until I'm fully bolted.
jwco5.3 is offline   Reply With Quote Quick reply to this message
Old 10-19-2012, 01:31 PM   #125 (permalink)
Senior Member
 
dnorris89's Avatar
 
Join Date: Jul 2009
Location: Philly
Posts: 2,896
Don
is the throttle body from an RL the same as the mdx or no?
dnorris89 is offline   Reply With Quote Quick reply to this message
Old 10-19-2012, 04:39 PM   #126 (permalink)
....................
 
0720Steve's Avatar
 
Join Date: Feb 2007
Posts: 69,689
2009+ rl shawd is same as 2009+ tl-s. 2010+ mdx is same as 2010+ zdx. think i got the years right there.
0720Steve is offline   Reply With Quote Quick reply to this message
Old 10-19-2012, 06:14 PM   #127 (permalink)
Senior Member
 
dnorris89's Avatar
 
Join Date: Jul 2009
Location: Philly
Posts: 2,896
Don
Thanks.


Sent from my iPhone using Autoguide
dnorris89 is offline   Reply With Quote Quick reply to this message
Old 11-12-2012, 02:13 PM   #128 (permalink)
Senior Member
 
justin13031's Avatar
 
Join Date: Oct 2010
Location: nc
Age: 29
Posts: 831
Justin Jacobs
So I have the imt sc inlet and the p2r adapter for the zdx tb and it doesnt fit the imt inlet right .... it bolts up but it covers up the 2 hose hook ups ??? Does anyone have their zdx tb hooked to their imt inlet? if so how did you do it?
justin13031 is offline   Reply With Quote Quick reply to this message
Old 11-12-2012, 03:07 PM   #129 (permalink)
Senior Member
 
mw1978's Avatar
 
Join Date: Dec 2006
Location: EUROPE (Poland)
Age: 36
Posts: 596
Marcin
i used imt tb adapter
mw1978 is offline   Reply With Quote Quick reply to this message
Old 11-12-2012, 03:36 PM   #130 (permalink)
Senior Member
 
Join Date: May 2008
Location: Long Island, NY
Posts: 564
Stefan
wow started this thread 4 months ago. just installed the aftercooler this weekend along with the imt inlet and mdx tb. runs great except the tb si way out of wack. dont know if it needs to be calibrated but i know i need to do an idle relearn. has anyone had issues going from stock to a tb this big?
toucansam1203 is offline   Reply With Quote Quick reply to this message
Old 11-12-2012, 03:49 PM   #131 (permalink)
there is no spoon

 
Join Date: May 2006
Posts: 16,805
Did you put a gasket or sealant on every metal-metal contact point? I've swapped TB's on this car many, many times over the last 5 years and have never needed to do a relearn. Basically what I'm saying is, are you sure you don't have a vacuum leak?
__________________
becauseHONDA™
mucter is offline   Reply With Quote Quick reply to this message
Old 11-13-2012, 09:14 AM   #132 (permalink)
Senior Member
 
Join Date: May 2008
Location: Long Island, NY
Posts: 564
Stefan
yeah everything has a gasket. and i have checked seem with carb cleaner and havent been able to find a thing. i dont know whats going on but i can barely drive the thing its gotten so much worse just from yesterday
toucansam1203 is offline   Reply With Quote Quick reply to this message
Old 11-15-2012, 03:22 PM   #133 (permalink)
Senior Member
 
Join Date: May 2008
Location: Long Island, NY
Posts: 564
Stefan
tb is sitting right next to me at work right now. there is no screw in that channel as some people have. but i have the imt barb plugged into where the mdx map sensor would go, and then the evap hose connects to it. the tb was tight to the gasket and inlet when i took it off. it really seems like it has to be some sort of tune issue or something. i mean wouldnt that make sense since the opening is so much larger than stock?
toucansam1203 is offline   Reply With Quote Quick reply to this message
Old 01-26-2013, 07:15 PM   #134 (permalink)
Senior Member
 
justin13031's Avatar
 
Join Date: Oct 2010
Location: nc
Age: 29
Posts: 831
Justin Jacobs
Got my rdx tb on and calibrated it by the lesser known way. unpluged bat 20 min then started it up and just let it idle for 30 min. Seems like the procedure took bc the idle isnt jumping like crazy but it has an issue.. It will idle just fine at 1k but once in gear and driving down the road the rpm will drop below 500 every time I shift to N . . It drives and accelarates just fine untill I shift to N and the rpm's fall back down and go below 500 , it chokes, and then raises back to 1k steady where it should be ???? Any ideas or anyone else have this issue..
justin13031 is offline   Reply With Quote Quick reply to this message
Old 01-27-2013, 05:28 PM   #135 (permalink)
1* Man
 
Steve42790's Avatar
 
Join Date: Jun 2010
Location: NJ
Posts: 19,313
Scubaaaaaaaaaaaaaaaaaaaaa
Quote:
Originally Posted by justin13031 View Post
Got my rdx tb on and calibrated it by the lesser known way. unpluged bat 20 min then started it up and just let it idle for 30 min. Seems like the procedure took bc the idle isnt jumping like crazy but it has an issue.. It will idle just fine at 1k but once in gear and driving down the road the rpm will drop below 500 every time I shift to N . . It drives and accelarates just fine untill I shift to N and the rpm's fall back down and go below 500 , it chokes, and then raises back to 1k steady where it should be ???? Any ideas or anyone else have this issue..
I had the same exact issue! I was being tuned by Vit at the time, i guess he adjust my tune a little so now its not doing it at all anymore. If you were tuned by vit ask him to fix it, or whoever your tuner was.
Steve42790 is online now   Reply With Quote Quick reply to this message
Old 01-27-2013, 07:51 PM   #136 (permalink)
Senior Member
 
justin13031's Avatar
 
Join Date: Oct 2010
Location: nc
Age: 29
Posts: 831
Justin Jacobs
^^^ Thanks bud! I am currently being tuned by vit as well. Im waiting for his reply to my datalog to see If he knows what is up. If it turns out to just be in the tune that would be great! If not then I have alot of troubleshooting to do Did you just install a rdx tb when you had the problem? How many revisions did it take to fix it up ?
justin13031 is offline   Reply With Quote Quick reply to this message
Old 01-28-2013, 04:53 AM   #137 (permalink)
Senior Member
 
mw1978's Avatar
 
Join Date: Dec 2006
Location: EUROPE (Poland)
Age: 36
Posts: 596
Marcin
first sorry for english

guys i had the same issue with my ZDX TB and CTSC. I did 10 times relearn procedure and still the same revs bouncing when car stop 1000-1600 and when i drove the car and set to N up and down. WHAT I DID: removed ZDX and mounted STOCK. Used voltometr and check VOLTS on first and third wire. On the forum is topic about seting TSX TB so you can check which wire you have to meassure. When i check volts on that wires i swaped TB and set throtte body plate using alen bolts in the same way as stock TB
More clear i had in ZDX TB the same volts on wire as on stock TB. Guys check again this small bolt inside TB where seat MAP sensor.
SInce that voltage setings my problem gone without relearn procedure....

hope you understand me!!!

Last edited by mw1978; 01-28-2013 at 04:55 AM.
mw1978 is offline   Reply With Quote Quick reply to this message
Old 03-27-2013, 10:03 AM   #138 (permalink)
Senior Member
 
Aydelz's Avatar
 
Join Date: May 2009
Location: QueeeeeNs
Posts: 1,535
does anybody know if the MDX throttle body will fit on a cte sc or do i need an inlet or adapter to have it fit?
Aydelz is offline   Reply With Quote Quick reply to this message
Old 03-27-2013, 10:04 AM   #139 (permalink)
Senior Member
 
Aydelz's Avatar
 
Join Date: May 2009
Location: QueeeeeNs
Posts: 1,535
is there an adapter or do i need an inlet to run a mdx throttle body on a cte SC
Aydelz is offline   Reply With Quote Quick reply to this message
Old 03-27-2013, 10:29 AM   #140 (permalink)
Senior Member
 
the sled's Avatar
 
Join Date: Sep 2009
Location: South Florida
Age: 27
Posts: 341
Andrew
need either the P2R adapter or the IMT inlet
the sled is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 8th Generation Honda Civic Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Non-Si Billet Throttle Bodies? haulin79 Intake & Spacer Discussion 1 09-07-2010 04:13 PM
Individual Throttle Bodies DeckSi Bolt-Ons And All-Motor 1 03-27-2009 10:51 AM
Throttle Bodies Gimenez Civic SI 11 02-12-2008 11:23 PM
Individual Throttle Bodies? zrod_si Bolt-Ons And All-Motor 12 01-29-2008 03:43 AM
throttle bodies fabonx7 Bolt-Ons And All-Motor 9 05-11-2006 11:10 PM


All times are GMT -4. The time now is 03:34 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
copyright 8thcivic.com - all rights reserved